$re = '/(?:\bis\b)?((?:(?!\bis\b)(?:What\s+is\b)?.?)+)/';
$str = 'is What is this and Who is this What is cool What isisisis is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is is is is this what is What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);