const regex = /(?:\bis\b)?((?:(?!\bis\b)(?:What\s+is\b)?.?)+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bis\\b)?((?:(?!\\bis\\b)(?:What\\s+is\\b)?.?)+)', 'g')
const str = `is What is this and Who is this What is cool What isisisis is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is is is is this what is What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}