import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bis\\b)?((?:(?!\\bis\\b)(?:What\\s+is\\b)?.?)+)";
final String string = "is What is this and Who is this What is cool What isisisis is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is is is is this what is What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is What is this and this is cool What is this is is is";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}