using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?#constructor)([a-z0-9]{2}).(?#class)([a-z0-9]{2}).(?#product)0*([a-z0-9]+).(?#voltage)0*([a-z0-9]+)V.(?#attr2)0*([a-z0-9]+).{2}(?#version)([a-z0-9]{2}).(?#revision)([a-z0-9]).(?#batch)([a-z0-9])";
string input = @"OE-PK-00LV-048V-300Ah-v01.0B0";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}