re = /^(?#constructor)([a-z0-9]{2}).(?#class)([a-z0-9]{2}).(?#product)0*([a-z0-9]+).(?#voltage)0*([a-z0-9]+)V.(?#attr2)0*([a-z0-9]+).{2}(?#version)([a-z0-9]{2}).(?#revision)([a-z0-9]).(?#batch)([a-z0-9])/mi
str = 'OE-PK-00LV-048V-300Ah-v01.0B0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end