import re
regex = re.compile(r"^(?#constructor)([a-z0-9]{2}).(?#class)([a-z0-9]{2}).(?#product)0*([a-z0-9]+).(?#voltage)0*([a-z0-9]+)V.(?#attr2)0*([a-z0-9]+).{2}(?#version)([a-z0-9]{2}).(?#revision)([a-z0-9]).(?#batch)([a-z0-9])", flags=re.MULTILINE | re.IGNORECASE)
test_str = "OE-PK-00LV-048V-300Ah-v01.0B0"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")