import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?#constructor)([a-z0-9]{2}).(?#class)([a-z0-9]{2}).(?#product)0*([a-z0-9]+).(?#voltage)0*([a-z0-9]+)V.(?#attr2)0*([a-z0-9]+).{2}(?#version)([a-z0-9]{2}).(?#revision)([a-z0-9]).(?#batch)([a-z0-9])";
final String string = "OE-PK-00LV-048V-300Ah-v01.0B0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}