using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)'|'(?=\s)";
string substitution = @"";
string input = @"CREATE TABLE 'Item_Value' ( 'itemID' Integer not NULL, 'value' Integer, 'currencyType' TEXT, PRIMARY KEY(itemID) );
INSERT INTO Item_Value (itemID,value,currencyType) VALUES (2,55,'CREDITS'),
(20,60,'CREDITS'),
(22,310,'CREDITS'),
(23,310,'CREDITS'),
(24,75,'CREDITS'),";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}