use strict;
my $str = 'CREATE TABLE \'Item_Value\' ( \'itemID\' Integer not NULL, \'value\' Integer, \'currencyType\' TEXT, PRIMARY KEY(itemID) );
INSERT INTO Item_Value (itemID,value,currencyType) VALUES (2,55,\'CREDITS\'),
(20,60,\'CREDITS\'),
(22,310,\'CREDITS\'),
(23,310,\'CREDITS\'),
(24,75,\'CREDITS\'),';
my $regex = qr/(?<=\s)'|'(?=\s)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";