const regex = /(?<=\s)'|'(?=\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)\'|\'(?=\\s)', 'g')
const str = `CREATE TABLE 'Item_Value' ( 'itemID' Integer not NULL, 'value' Integer, 'currencyType' TEXT, PRIMARY KEY(itemID) );
INSERT INTO Item_Value (itemID,value,currencyType) VALUES (2,55,'CREDITS'),
(20,60,'CREDITS'),
(22,310,'CREDITS'),
(23,310,'CREDITS'),
(24,75,'CREDITS'),`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);