using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\),\s(\d+\s*,\s*[\w.]+\s*)";
string substitution = @"";
string input = @"::Tile(1,8), 92, water.png";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}