const regex = /\),\s(\d+\s*,\s*[\w.]+\s*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\),\\s(\\d+\\s*,\\s*[\\w.]+\\s*)', 'gm')
const str = `::Tile(1,8), 92, water.png`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);