// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\),\s(\d+\s*,\s*[\w.]+\s*)").unwrap();
let string = "::Tile(1,8), 92, water.png";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}