$re = '/\),\s(\d+\s*,\s*[\w.]+\s*)/m';
$str = '::Tile(1,8), 92, water.png';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;