# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\d+\b//g;t' <<< "850 7th Ave Frnt 1, New York, NY 10019"