using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+\b";
string substitution = @"";
string input = @"850 7th Ave Frnt 1, New York, NY 10019";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}