const regex = /\b\d+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\b', 'g')
const str = `850 7th Ave Frnt 1, New York, NY 10019`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);