#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b((l['’]\p{L})|les\s)"
Local $sString = "l'écosystème " & @CRLF & _
"l'ecosysteme " & @CRLF & _
"les things " & @CRLF & _
"les écosysteme " & @CRLF & _
"les tings " & @CRLF & _
"l'ting " & @CRLF & _
"l'âme" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")