import re
regex = re.compile(r"\b((l['’]\p{L})|les\s)")
test_str = ("l'écosystème \n"
"l'ecosysteme \n"
"les things \n"
"les écosysteme \n"
"les tings \n"
"l'ting \n"
"l'âme\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")