// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b((l['’]\p{L})|les\s)").unwrap();
let string = "l'écosystème
l'ecosysteme
les things
les écosysteme
les tings
l'ting
l'âme
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}