$re = '/\b((l[\'’]\p{L})|les\s)/';
$str = 'l\'écosystème
l\'ecosysteme
les things
les écosysteme
les tings
l\'ting
l\'âme
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);