using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ParaStyle:f><cConditionalText:HiddenNote>f0002<cConditionalText:><CharStyle:fr>1:1 <CharStyle:><CharStyle:fq>پولس <CharStyle:><CharStyle:ft>در زمان نگارش عهد جدید رسم بر این بود که نام نویسندۀ نامه در ابتدای نامه ذکر شود. نام عبرانی پولس، شائول بود (ر.ک. کار. ۱۳: ۹).<CharStyle:>";
string input = @"100
3
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}