$re = '/<ParaStyle:f><cConditionalText:HiddenNote>f0002<cConditionalText:><CharStyle:fr>1:1 <CharStyle:><CharStyle:fq>پولس <CharStyle:><CharStyle:ft>در زمان نگارش عهد جدید رسم بر این بود که نام نویسندۀ نامه در ابتدای نامه ذکر شود. نام عبرانی پولس، شائول بود (ر.ک. کار. ۱۳: ۹).<CharStyle:>/i';
$str = '100
3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);