package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<ParaStyle:f><cConditionalText:HiddenNote>f0002<cConditionalText:><CharStyle:fr>1:1 <CharStyle:><CharStyle:fq>پولس <CharStyle:><CharStyle:ft>در زمان نگارش عهد جدید رسم بر این بود که نام نویسندۀ نامه در ابتدای نامه ذکر شود. نام عبرانی پولس، شائول بود (ر.ک. کار. ۱۳: ۹).<CharStyle:>`)
var str = `100
3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}