import Foundation
let pattern = #"<ParaStyle:f><cConditionalText:HiddenNote>f0002<cConditionalText:><CharStyle:fr>1:1 <CharStyle:><CharStyle:fq>پولس <CharStyle:><CharStyle:ft>در زمان نگارش عهد جدید رسم بر این بود که نام نویسندۀ نامه در ابتدای نامه ذکر شود. نام عبرانی پولس، شائول بود (ر.ک. کار. ۱۳: ۹).<CharStyle:>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
100
3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)