using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(b|i)>(.*?)(<br>)+(.*?)<\/\1>";
string substitution = @"<$1>$2</$1>$3<$1>$4</$1>";
string input = @"<b> текст <i>вложение <br> </i> переход</b><b> текст <i>вложение <br> </i> переход</b><b> текст <i>вложение <br> </i> переход</b>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}