$re = '/<(b|i)>(.*?)(<br>)+(.*?)<\/\1>/';
$str = '<b> текст <i>вложение <br> </i> переход</b><b> текст <i>вложение <br> </i> переход</b><b> текст <i>вложение <br> </i> переход</b>';
$subst = "<$1>$2</$1>$3<$1>$4</$1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;