import Foundation
let pattern = #"<(b|i)>(.*?)(<br>)+(.*?)<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<b> текст <i>вложение <br> </i> переход</b><b> текст <i>вложение <br> </i> переход</b><b> текст <i>вложение <br> </i> переход</b>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1>$2</$1>$3<$1>$4</$1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)