use strict;
my $str = '<b> текст <i>вложение <br> </i> переход</b><b> текст <i>вложение <br> </i> переход</b><b> текст <i>вложение <br> </i> переход</b>';
my $regex = qr/<(b|i)>(.*?)(<br>)+(.*?)<\/\1>/p;
my $subst = '<$1>$2</$1>$3<$1>$4</$1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";