import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\".*?\" [0-9]{3}";
final String string = "[16/Aug/2016:06:13:25 -0400] \"GET /file/ HTTP/1.1\" 302 random stuff ignore\n"
+ "[16/Aug/2016:06:13:25 -0400] \"\" 400 random stuff ignore";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}