import re
regex = re.compile(r"\".*?\" [0-9]{3}")
test_str = ("[16/Aug/2016:06:13:25 -0400] \"GET /file/ HTTP/1.1\" 302 random stuff ignore\n"
"[16/Aug/2016:06:13:25 -0400] \"\" 400 random stuff ignore")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")