// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"".*?" [0-9]{3}"#).unwrap();
let string = "[16/Aug/2016:06:13:25 -0400] \"GET /file/ HTTP/1.1\" 302 random stuff ignore
[16/Aug/2016:06:13:25 -0400] \"\" 400 random stuff ignore";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}