$re = '/".*?" [0-9]{3}/';
$str = '[16/Aug/2016:06:13:25 -0400] "GET /file/ HTTP/1.1" 302 random stuff ignore
[16/Aug/2016:06:13:25 -0400] "" 400 random stuff ignore';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);