#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""(?=(?:[^']*'[^']*')*[^']*$)"
Local $sString = ""foo" => 'foo'" & @CRLF & _
"'foo' => 'foo'" & @CRLF & _
"abc "foo" => abc 'foo'" & @CRLF & _
"foo "bar", "baz" => foo 'bar', 'baz'" & @CRLF & _
"abc 'foo "bar" baz' => abc 'foo "bar" baz'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")