$re = '/"(?=(?:[^\']*\'[^\']*\')*[^\']*$)/';
$str = '"foo" => \'foo\'
\'foo\' => \'foo\'
abc "foo" => abc \'foo\'
foo "bar", "baz" => foo \'bar\', \'baz\'
abc \'foo "bar" baz\' => abc \'foo "bar" baz\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);