re = /"(?=(?:[^']*'[^']*')*[^']*$)/
str = '"foo" => \'foo\'
\'foo\' => \'foo\'
abc "foo" => abc \'foo\'
foo "bar", "baz" => foo \'bar\', \'baz\'
abc \'foo "bar" baz\' => abc \'foo "bar" baz\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end