using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?=(?:[^']*'[^']*')*[^']*$)";
string input = @"""foo"" => 'foo'
'foo' => 'foo'
abc ""foo"" => abc 'foo'
foo ""bar"", ""baz"" => foo 'bar', 'baz'
abc 'foo ""bar"" baz' => abc 'foo ""bar"" baz'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}