#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(-?\d+)(\d\d\d)"
Local $sString = "-1234567890"
Local $sSubst = "$1,$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)