const regex = /^(-?\d+)(\d\d\d)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?\\d+)(\\d\\d\\d)', '')
const str = `-1234567890`;
const subst = `$1,$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);