use strict;
my $str = '-1234567890';
my $regex = qr/^(-?\d+)(\d\d\d)/p;
my $subst = '$1,$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";