using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?\d+)(\d\d\d)";
string substitution = @"$1,$2";
string input = @"-1234567890";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}