import re
regex = re.compile(r"([0-9]{2}:){3}[0-9]{2}")
test_str = ("@ This file written with the Avid Caption plugin, version 1\n\n"
"<begin subtitles>\n"
"00:00:08:00 00:00:14:03\n"
"070\n\n"
"00:00:14:03 00:01:02:19\n"
"085\n\n"
"00:01:02:19 00:01:37:04\n"
"075\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")