$re = '/^[0-9a-fA-F]+(?:[:-][0-9a-fA-F:]+)*(?:\r?\n[0-9a-fA-F]+(?:[:-][0-9a-fA-F:]+)*)*$/m';
$str = '123ABC:DEF456
0:1:2:3:4:5
12345
90210-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);