re = /^[0-9a-fA-F]+(?:[:-][0-9a-fA-F:]+)*(?:\r?\n[0-9a-fA-F]+(?:[:-][0-9a-fA-F:]+)*)*$/m
str = '123ABC:DEF456
0:1:2:3:4:5
12345
90210-1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end