import re
regex = re.compile(r"^[0-9a-fA-F]+(?:[:-][0-9a-fA-F:]+)*(?:\r?\n[0-9a-fA-F]+(?:[:-][0-9a-fA-F:]+)*)*$", flags=re.MULTILINE)
test_str = ("123ABC:DEF456\n"
"0:1:2:3:4:5\n"
"12345\n"
"90210-1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")