using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\w+(?:-\w+)*\((?:[a-fA-F0-9]+(?:-[a-fA-F0-9]+)+|\w+)\)+}";
string input = @"{abc_test(1))}
{abc_test(2dc7ba10-fe29-4de6-9282-a4ebc5eee87d))}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}