// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m){\w+(?:-\w+)*\((?:[a-fA-F0-9]+(?:-[a-fA-F0-9]+)+|\w+)\)+}").unwrap();
let string = "{abc_test(1))}
{abc_test(2dc7ba10-fe29-4de6-9282-a4ebc5eee87d))}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}