import re
regex = re.compile(r"{\w+(?:-\w+)*\((?:[a-fA-F0-9]+(?:-[a-fA-F0-9]+)+|\w+)\)+}", flags=re.MULTILINE)
test_str = ("{abc_test(1))}\n"
"{abc_test(2dc7ba10-fe29-4de6-9282-a4ebc5eee87d))}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")