const regex = new RegExp('{\\w+(?:-\\w+)*\\((?:[a-fA-F0-9]+(?:-[a-fA-F0-9]+)+|\\w+)\\)+}', 'gm')
const str = `{abc_test(1))}
{abc_test(2dc7ba10-fe29-4de6-9282-a4ebc5eee87d))}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}