using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((feature/.{1,5})|(maint/.{1,5})|(doc/.*)|(fix/.*)|(trivial/.*)|(revert-.*)|(release/.*)|(renovate/.*))$";
string input = @"fix/757";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}